Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

The most recent posts in iRedMail.

older | 1 | .... | 1315 | 1316 | (Page 1317) | 1318 | 1319 | .... | 1394 | newer

    0 0

    Any relevant error message in Postfix log file?


    0 0

    ZhangHuangbin wrote:
    NoOneYouKnow wrote:

    rm -f /lib/systemd/system/iredapd.service
    cp /opt/iredapd/rc_scripts/iredapd.service /lib/systemd/system
    rm -f /etc/systemd/system/multi-user.target.wants/iredapd.service
    rm -f /etc/systemd/system/iredapd.service
    systemctl enable iredapd

    This is exactly how/what iRedMail does to enable iredapd service.

    I have build a VM (VMWARE) using Ubuntu 18.04.1. The second "disk" was made in to a Volume Group (vg00) and /opt is a logical volume of vg00.

    I repeated the steps that NoOneYouKnow supplied and it worked perfectly!!! Thanks!!

    Greg


    0 0

    ZhangHuangbin wrote:

    You should try with '-h':

    mysql -h <remote-mysql-server-ip> -u amavisd -p

    I think I pasted the wrong text in my previous message (LOL), but it was the same:

    # mysql -h 10.133.60.23 -u amavisd -p
    Enter password:
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 6363
    Server version: 5.7.23-0ubuntu0.18.04.1 (Ubuntu)
    
    Copyright (c) 2000, 2018, Oracle and/or its affiliates. All rights reserved.
    
    Oracle is a registered trademark of Oracle Corporation and/or its
    affiliates. Other names may be trademarks of their respective
    owners.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    mysql>

    0 0
  • 10/03/18--14:06: 504 Gateway Time-out Nginx
  • Using 0.9.8
    nginix
    debian
    mariadb
    Roundcube

    No Sogo

    90% of the time when i try to connect to the Iredmail admin I get this, 10% of the time it will work for a few minutes and the die.

    1 email account
    av/antispam disabled.

    I have tried reinstalling mutliple times. My server doesn't seem particularly busy but nothing works.

    Please help if you can.


    0 0

    Dear Zhang,

       I thought you have said it is very easy, I found out it need to do many things on ldap, like adding the schema using ldapadd, ldapmodify command, and it will end up in no sufficient right.
      I am thinking if we got it right and smooth, it could be great help for iredmail community, because i believe some else will use iredadmin as their smb server ldap server presently and future, and this guide will help them most.

    Thanks
    Napoleon


    0 0

    Dear Zhang,
       i found out after i install samba on the iredmail server and check the samba schema, the error message is gone, and it seem like connect successfully to the iredmail server by freenas. i can see the samba.schema using ldap software, but what should i do next? as every user in iredmail did not have samba attribute.

    Thanks
    Napoleon


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release):      0.9.8
    - Linux/BSD distribution name and version: CentOS Linux release 7.5.1804 (Core)
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL):  LDAP
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro? - Yes
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    Issue
    When I am trying to set forwarding of a user from Admin Pro panel from user's settings > forwarding, it is not saving given address and setting Enable mail forwarding check box. Upon saving it shows message as Profile updated success, however it is not saving in back end as well as it is not activating actual forwarding. I have attached "forwarding-screen.png" screenshot for review.

    Require help to get this sorted.


    0 0

    I've not installed SOGO so I don't think it can be the prefork thing I've seen posted on many threads.

    I will try the other fix posted but it seems to be targetting 502 bad gateway instead of 504.


    0 0

    please do not spam this forum - Admin to action please.


    0 0

    ZhangHuangbin wrote:

    What's the error if you send a new testing email?


    This the error we are getting

    "Recipient address rejected: Intentional policy rejection, please try again later; "

    Another it is not giving error but recipient does not receive the mail and when i check in maillog it create (queue active)


    0 0
  • 10/04/18--07:18: Re: Blocking Fake Emails
  • As has been answered already in some topics, the correct place is to fight these kind of spams is in SpamAssassin.
    I have no clue for the moment on how to construct such a ruleset, but if/when I do I will post a link.
    The starting point might be: https://wiki.apache.org/spamassassin/

    Rules should, I think, be placed in /etc/mail/spamassassin/local.cf

    Free beer to the winner ;-)

    Note: the problem might be "false negative reporting", but start with setting the spamscore to "+0.1" and check the result.
    Test using "telnet mailserver.tld 25" using:  mail from: correct.sender@tld, rcpt to: correct.recipient@tld, data, To: correct.recipient, from: Fake.sender, and view the raw mail message (or all headers)
    Regards


    0 0

    0.9.8 MARIADB edition

    Linux Debian 9.4

    NGinx

    no Pro

    Ok that is out of the way. I had everything working fine then I went and got a SSL certificate and installed it and rerouted 80 to 443 and now iredadmin doesnt come up. IF I go to the web URL it just redirects to the main website. I tried backing out my changes and it still doesn't work.

    default.conf

    #
    # Note: This file must be loaded before other virtual host config files,
    #
    # HTTP
    server {
        # Listen on ipv4
        listen 80;
    
        # Listen on ipv6.
        # Note: this setting listens on both ipv4 and ipv6 with Nginx release
        #       shipped in some Linux/BSD distributions.
        #listen [::]:80;
        
        root /srv/example;
        index index.php index.html;
    
        include /etc/nginx/templates/misc.tmpl;
        include /etc/nginx/templates/ssl.tmpl;
        include /etc/nginx/templates/iredadmin.tmpl;
        #include /etc/nginx/templates/roundcube.tmpl;
        #include /etc/nginx/templates/sogo.tmpl;
        include /etc/nginx/templates/netdata.tmpl;
        include /etc/nginx/templates/php-catchall.tmpl;
    
        location ~ \.php$ {
          fastcgi_split_path_info ^(.+\.php)(/.+)$;
          fastcgi_pass 127.0.0.1:9000;
          fastcgi_index index.php;
          include fastcgi_params;
        }
    
        server_name 10.10.10.10;
        #return 301 https://example.com;
    }

    I haven't changed any other conf files except the SSL conf file which isn't being read because I am using http. Unless you think it is being read?


    0 0

    Spam everywhere sad

    I'm still a little confused about this issue. but few questions first:

    - Did you migrate mail accounts from another server?
    - Do the forwarding addresses exist on your server?


    0 0

    How much memory does your server have?


    0 0

    napoleon.lam wrote:

    but what should i do next? as every user in iredmail did not have samba attribute.

    I'm not sure why Samba schema is required by FreeNAS, i wonder is it possible to disable Samba schema requirement in FreeNAS web admin panel?


    0 0

    mikal wrote:

    My IOS device gives me the following errormessage when I try to send:
    "Can not send e-mail - The message was rejected by the server" (translated from norwegian)

    Disable fail2ban service and try again.

    if not blocked by fail2ban, try this:

    1: send email again
    2: check sogo log file and postfix log immediately to find relevant error/log.

    If there's no any log on server side, better double check the mail server settings in iPhone.


    0 0

    Do you actually have sql user 'admin_iredmail'@'10.133.59.88'?


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.8
    - Linux/BSD distribution name and version: CentOS 7
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): MariaDB
    - Web server (Apache or Nginx):Nginx
    - Manage mail accounts with iRedAdmin-Pro?
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    Hi,

    I am trying to install iRedMail on a machine that is connected to another machine's MariaDB via SSH tunnerl - therefore if I do:

    $ mysql -h 127.0.0.1 -uroot -p

    I actually connect to MariaDB installed on the remote machine.

    Following this page (https://docs.iredmail.org/install.iredm … erver.html) I tried installing iRedMail with:

    USE_EXISTING_MYSQL='YES' MYSQL_SERVER_ADDRESS='127.0.0.1' MYSQL_SERVER_PORT='3306' MYSQL_ROOT_USER='admin_iredmail' MYSQL_ROOT_PASSWD='admin_password' MYSQL_GRANT_HOST='127.0.0.1' bash iRedMail.sh

    but the installation process keeps trying using the socket instead of establishing a TCP connection:

    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    Is there a way to force the installation - and then the whole solution - to use TCP? Looking at the script it looks like if

    MYSQL_SERVER_ADDRESS = 127.0.0.1

    it will treat it as localhost - which defaults to socket.


    0 0

    sherman.lilly wrote:

    now iredadmin doesnt come up. IF I go to the web URL it just redirects to the main website.

    What's the relevant log in Nginx log file?


    0 0

    berthageorge wrote:

    "Recipient address rejected: Intentional policy rejection, please try again later; "

    FYI:
    https://docs.iredmail.org/errors.html#i … gain-later


older | 1 | .... | 1315 | 1316 | (Page 1317) | 1318 | 1319 | .... | 1394 | newer