Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

The most recent posts in iRedMail.

older | 1 | .... | 1339 | 1340 | (Page 1341) | 1342 | 1343 | .... | 1394 | newer

    0 0

    Look this post https://forum.iredmail.org/topic8740-ir … e-and.html 

    The same program as you.


    0 0

    dovecot log :
    mail dovecot: master: Error: service(lmtp): command startup fail                                              ed, throttling for 2 secs
    lmtp: Fatal: master: service(lmtp): child 2491 ret urned error 89                                             urned error 89 (Fatal failure)

    mail dovecot: imap-login: Fatal: Invalid ssl_protocols setting:                                               Unknown protocol 'SSLv2'

    imap.log
    mail dovecot: imap-login: Fatal: Invalid ssl_protocols setting: Unknown protocol 'SSLv2'

    lda.log
    mail dovecot: lmtp(2379): Fatal: Invalid ssl_protocols setting: Unknown protocol 'SSLv2'


    Interesting that these errors only appeared this morning on the log with last time i try to connect .


    0 0

    No, I can see the amavis.service file only in /run/systemd/generator.late/amavis.service. But as I said previously this is an auto generated service file...


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.7 MYSQL edition
    - Linux/BSD distribution name and version: ubuntu 16.04
    - Store mail accounts in which backend (MySQL):
    - Web server (Apache or Nginx):Nginx
    - Manage mail accounts with iRedAdmin-Pro? Yes iRedAdmin-Pro-SQL-2.8.0
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.

    My Iredadmin Interface is failing to come up and getting the error below from ;
    :/var/log/nginx# tail -f error.log | grep iredadmin
    2018/10/31 11:28:13 [error] 12450#0: *19096 upstream timed out (110: Connection timed out) while reading response header from upstream, client: xx.x.x.xx, server: xxxx.xxx.xx.xx, request: "GET  iredadmin/dashboard/checknew HTTP/1.1", upstream: "uwsgi://unix:/var/run/uwsgi_iredadmin.socket", host: "xxxx.xxx.xx.xx"
    In the amavisd.msgs     database i have 1103946
    In the amavisd.msgrcpt     database i have 1105946
    I have tried to delete records in DB those files above using the python script (cleanup_amavisd_db.py) but it taking a long time and the webinterface is still down.

    My uwsgi service is running as shown below

    root@xxxx:/var/log/nginx# ps aux | grep uwsgi
    iredadm+  3071  0.0  0.0  69084  9724 ?        S    10:57   0:00 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+  3078  0.0  0.0 256244 27184 ?        S    10:57   0:00 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+  3079  0.0  0.0 256244 27184 ?        S    10:57   0:00 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+  3080  0.0  0.1 264860 33912 ?        S    10:57   0:01 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+  3081  0.0  0.0 256244 27184 ?        S    10:57   0:00 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+  3084  0.0  0.0 256900 27868 ?        S    10:57   0:00 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+  7646  0.0  0.0  68692  9384 ?        S    07:38   0:00 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+  7652  0.0  0.0  75104  8872 ?        S    07:38   0:00 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+  7653  0.0  0.0  75104  8872 ?        S    07:38   0:00 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    root     13854  0.0  0.0   9468  2008 pts/6    T    07:59   0:00 more /usr/share/uwsgi/conf/default.ini
    iredadm+ 14846  0.0  0.1 264912 33928 ?        S    08:01   0:01 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+ 14847  0.0  0.1 258080 33028 ?        S    08:01   0:01 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+ 14848  0.0  0.0 257712 32584 ?        S    08:01   0:01 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    iredadm+ 14849  0.0  0.1 264672 33712 ?        S    08:01   0:01 /usr/bin/uwsgi --ini /usr/share/uwsgi/conf/default.ini --ini /etc/uwsgi/apps-enabled/iredadmin.ini --daemonize /var/log/uwsgi/app/iredadmin.log
    root     27455  0.0  0.0  11764  2204 pts/12   S+   11:36   0:00 grep --color=auto uwsgi



    Wed Oct 31 11:31:50 2018 - uwsgi_response_write_headers_do(): Broken pipe [core/writer.c line 216]
    IOError: write error xxxx.xxx.xx.xx[pid: 3080|app: 0|req: 5/7] xx.xxx.xx.xxx () {54 vars in 1141 bytes} [Wed Oct 31 11:06:18 2018] GET /iredadmin/dashboard/checknew => generated 0 bytes in 1531947 msecs (HTTP/1.1 200) 2 headers in 0 bytes (0 switches on core 0)

    Is there anybody with a quick fix to this?
    Thanks
    MKK


    0 0

    Apache's default site file is this

    <VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName "host1.com"

        <Directory /srv/www/host1>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order deny,allow
            Allow from all
        </Directory>

        DocumentRoot /srv/www/host1
        WSGIScriptAlias / /srv/www/host1/apache/django.wsgi

    </VirtualHost>

    <VirtualHost *:80>

        ServerAdmin webmaster@localhost
        ServerName "host2.com"
        ProxyRequests Off

        <Proxy *>
        Order deny,allow
        Allow from all
        </Proxy>

        ProxyPass / http://host1.com/host2
        ProxyPassReverse / http://host1.com/host2

    </VirtualHost>
    If anyone face printer issue click here https://www.hpsupporthelpline.com/blog/ … r-code-20/


    0 0
  • 10/31/18--03:45: The problem with SMTPs
  • ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release):
    - Linux/BSD distribution name and version:
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL):
    - Web server (Apache or Nginx):
    - Manage mail accounts with iRedAdmin-Pro?
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====
    ======== Required information ====
    - iRedMail version: 0.9.8
    - Linux distribution name and version: CentOS Linux release 7.5.1804 (Core)
    - Store mail accounts in which backend: MySQL
    - Web server: nginx/1.12.2
    - Manage mail accounts with iRedAdmin-Pro? iRedAdmin-Pro-SQL 2.9.0
    ====

    Good day.
    I combined two iredmail mailservers into one running iRedAdmin-Pro.
    I transferred the contents of mailboxes from /../vmail/vmail1/domain/ to my main server and transferred the MySQL tables roundcubemail.users, roundcubemail.identities, vmail.mailbox and vmail.forwardings.
    On both servers smtps sending was enabled (TCP 465). This is enabled in the postfix and firewalld settings.
    After merging, the transferred accounts cannot send mail with SSL (465), they receive the error
    "554 5.7.1 <user @ domain>: Recipient address rejected: Sender is not the same as SMTP authenticate username".

    Accounts that were originally on the server and new accounts any domain can use SSL SMTPs (465).
    I checked the account settings Sending mails via SMTP over TLS / SSL enabled, like everyone else. In the vmail.mailbox table, the parameter enablesmtpsecured = 1 for all accounts.

    I found
    https://docs.iredmail.org/errors.html#r … -username,
    but I only use mailbox, not alias, not maillist .
    After changing the SMTPS client settings from SSL 465 to STARTLS 587, the client starts working instantly.

    What did I do wrong and is it possible to return everything?


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release):
    - Linux/BSD distribution name and version:
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL):
    - Web server (Apache or Nginx):
    - Manage mail accounts with iRedAdmin-Pro?
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    What is the procedure for releasing quarantined messages with the opensource version?

    I've tried amavisd-release but I get an error:
    Can't connect to UNIX socket /var/amavis/amavisd.sock: No such file or directory at /usr/sbin/amavisd-release line 271.

    Thanks.


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.8
    - Linux/BSD distribution name and version: Debian 9
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL):  LDAP
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro? No
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    Hi,

    I'd like know if it's possible to create a noreply mailbox AND a noreply mailAlias. If yes, how?
    I've tried playing with the "enabledService" for a mailAlias and a User but I can't quite get what I want.
    For example, if I have a "general@domain.com" as user and a "noreply@domain.com" as alias from which general can send mail with, I'd like it impossible for an external mail user to reply to general using "noreply@domain.com".

    So far my LDAP objects when I create an mailAlias are with these values :
    mail : noreply@domain.com
    accountStatus : active
    enabledService: mail, deliver
    cn : Noreply TEST
    mailForwardingAddress : general@domain.com
    objectClass : mailAlias, top

    I've tried deleting "mail" and "deliver" on the services, adding "deliver" or "mail" in disabledService. But none of it worked. Maybe there's a combination on enabled/disabled services that I don't know.

    This is what I get if I send back a reply to "noreply@domain.com", forwarding to "general@domain.com" with "external.user@domain.com". In my LDAP, I've added  the attribute
    disabledService : mail, deliver
    to the mailAlias "noreply@domain.com". It does nothing, apparently.
    Ideally, I'd like such reply to be dropped.

    Oct 31 14:25:53 smtp postfix/postscreen[30167]: CONNECT from [209.85.166.175]:50518 to [loca IP]:25
    Oct 31 14:25:59 smtp postfix/postscreen[30167]: PASS OLD [209.85.166.175]:50518
    Oct 31 14:25:59 smtp postfix/smtpd[30172]: connect from mail-it1-f175.google.com[209.85.166.175]
    Oct 31 14:25:59 smtp postfix/smtpd[30172]: Anonymous TLS connection established from mail-it1-f175.google.com[209.85.166.175]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
    Oct 31 14:26:00 smtp postfix/smtpd[30172]: 315052057F: client=mail-it1-f175.google.com[209.85.166.175]
    Oct 31 14:26:00 smtp postfix/cleanup[30142]: 315052057F: message-id=<CAAeq73dEenQh6LZ_nCuL+_TgygP488YGJ3uRtU2e4AMVYdbufg@mail.gmail.com>
    Oct 31 14:26:00 smtp postfix/qmgr[1438]: 315052057F: from=<external.user@gmail.com>, size=3516, nrcpt=1 (queue active)
    Oct 31 14:26:00 smtp postfix/smtpd[30172]: disconnect from mail-it1-f175.google.com[209.85.166.175] ehlo=2 starttls=1 mail=1 rcpt=1 data=1 quit=1 commands=7
    Oct 31 14:26:05 smtp postfix/10025/smtpd[30148]: connect from localhost[127.0.0.1]
    Oct 31 14:26:05 smtp postfix/10025/smtpd[30148]: 3A5FA20614: client=localhost[127.0.0.1]
    Oct 31 14:26:05 smtp postfix/cleanup[30142]: 3A5FA20614: message-id=<CAAeq73dEenQh6LZ_nCuL+_TgygP488YGJ3uRtU2e4AMVYdbufg@mail.gmail.com>
    Oct 31 14:26:05 smtp postfix/qmgr[1438]: 3A5FA20614: from=<external.user@gmail.com>, size=4071, nrcpt=1 (queue active)
    Oct 31 14:26:05 smtp postfix/10025/smtpd[30148]: disconnect from localhost[127.0.0.1] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
    Oct 31 14:26:05 smtp amavis[15805]: (15805-01) Passed CLEAN {RelayedInbound}, [209.85.166.175]:50518 [209.85.166.175] <external.user@gmail.com> -> <general@domain.com>, Queue-ID: 315052057F, Message-ID: <CAAeq73dEenQh6LZ_nCuL+_TgygP488YGJ3uRtU2e4AMVYdbufg@mail.gmail.com>, mail_id: WtcR_IzWQ9YH, Hits: -0.098, size: 3516, queued_as: 3A5FA20614, dkim_sd=20161025:gmail.com, 4827 ms, Tests: [DKIM_SIGNED=0.1,DKIM_VALID=-0.1,DKIM_VALID_AU=-0.1,FREEMAIL_FROM=0.001,HTML_MESSAGE=0.001,SPF_PASS=-0.001,URIBL_BLOCKED=0.001]
    Oct 31 14:26:05 smtp postfix/amavis/smtp[30143]: 315052057F: to=<general@domain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.1, delays=0.25/0/0.01/4.8, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3A5FA20614)
    Oct 31 14:26:05 smtp postfix/qmgr[1438]: 315052057F: removed
    Oct 31 14:26:05 smtp postfix/pipe[30178]: 3A5FA20614: to=<general@domain.com>, relay=dovecot, delay=0.07, delays=0.01/0.03/0/0.03, dsn=2.0.0, status=sent (delivered via dovecot service)
    Oct 31 14:26:05 smtp postfix/qmgr[1438]: 3A5FA20614: removed

    I'm still trying to understand how everything is working on IredMail server so excuse me if there's something I missed in the documentation. Also, the other noreply topics don't seem to try a noreply alias, hence my own topic for it.

    I've got another question related to the attribute EnabledService. When we create an account using the iredadmin page, it fills this attribute with all these values :
    enabledService  :
    - mail
    - deliver
    - lda
    - lmtp
    - smtp
    - smtpsecured
    - pop3
    - pop3secured
    - pop3tls
    - imap
    - imapsecured
    - imaptls
    - managesieve
    - managesievesecured
    - sogo
    - sieve
    - sievesecured
    - forward
    - senderbcc
    - recipientbcc
    - internal
    - lib-storage
    - indexer-worker
    - doveadm
    - dsync
    - shadowaddress
    - displayedInGlobalAddressBook

    I understand some of these, but not all. And I guess there are some missing. Is there a documentation where we can read about all of these, to understand what effects they can have on the postfix configuration?

    Thank you!


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.6
    - Linux/BSD distribution name and version: Ubuntu 16.04
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro?
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====
    Hey Guys,

    2 questions in one thread.

    1) For some reason mail from my server, which is setup exactly as required and scores 99% on the mx checkers, barring DMARC obviously, is landing up directly in some users SPAM folders for some reason. Ive noticed this mainly happening with Office 365 users and also Mimecast users.

    We dont send any spam whatsoever, our main business that uses the account is an e-commerce business that does send out a lot of similar email, in the form of receipts and new order confirmations. I was reading a few forums online and specifically relating to Office 365 they say that the relay showing as relay=127.0.0.1[127.0.0.1] - showing local host could be part of the problem? Is this true, and if so, then how would i change this to show the actual mail server address there instead?

    Any other feedback on what might be the issue is also welcome.

    2) Second question, we use Zendesk in our business and have set it up that zendesk sends mails through our server. The problem is that they have so many outbound servers, that I have to go and add each ip to /opt/iredapd/settings.py in the MYNETWORKS variable.

    Again, is this the right method, or is there another way? Also, this variable doesnt seem to accept an IP range, so literally have to add each ip.

    Looking forward to some help!

    Thanks,
    Tay


    0 0

    on iOS device, you should add this account as an "Exchange" account (Settings -> Passwords & Accounts -> Add Account -> Exchange), it will ask you to type username and password.


    0 0

    Thank you very much. smile


    0 0

    Just logout and re-login is enough, no need to remove web browser cookies.

    Did you get this error every time you open a new page?


    0 0

    Edit file /etc/dovecot/dovecot.conf, find parameter "ssl_protocols =", then remove "SSLv2", restart dovecot service.


    0 0

    You can edit /etc/init.d/amavis instead, modify the comment line "Required-Start:".


    0 0

    - Try to stop uwsgi service first.
    - Run command: "ps aux | grep uwsgi", make sure no uwsgi process is running. If there're few, try to kill them with 'kill -9 <pid>' (replace <pid> by the real process id).
    - Start uwsgi service again.


    0 0
  • 10/31/18--15:54: Re: The problem with SMTPs
  • ppnm wrote:

    After changing the SMTPS client settings from SSL 465 to STARTLS 587, the client starts working instantly.

    The error message you pasted isn't related to this SSL/TLS setting change.

    "Sender is not the same as SMTP authenticate username", it means the smtp authentication username is different than the sender address specified in mail header.


    0 0
    0 0

    tayzee wrote:

    is landing up directly in some users SPAM folders for some reason.

    After email left your server, it's not under you control. You cannot tell others how to treat your email. So it's normal that it goes to Spam/junk folder, even you have correct DNS records, DKIM signing, etc.

    tayzee wrote:

    Also, this variable doesnt seem to accept an IP range,

    It does support IP range/network. You can find sample settings in file /opt/iredapd/libs/default_settings.py:

    # Trusted IP address or networks.
    # Valid formats:
    #   - Single IP address: 192.168.1.1
    #   - Wildcard IP range: 192.168.1.*, 192.168.*.*, 192.168.*.1
    #   - IP subnet: 192.168.1.0/24
    MYNETWORKS = []

    0 0

    Try to create noreply@ as a normal user, then remove "deliver" from "enabledService" values.


    0 0

    ... and, as said before... just add SPF records for each mail domain You are hosting, allowing your "big.iredmailhost.domain" as sender. This is the way to do it, also if You host Your own domain at google or other mail server providers


older | 1 | .... | 1339 | 1340 | (Page 1341) | 1342 | 1343 | .... | 1394 | newer