Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

The most recent posts in iRedMail.

older | 1 | .... | 1373 | 1374 | (Page 1375) | 1376 | 1377 | .... | 1394 | newer

    0 0

    artavec wrote:

    The mailing list manager seems to be in the "pro" package, which would be good for a commercial site, but is far outside my budget for charity work.

    mlmmj mailing list manager is a core component of iRedMail, you can manage mailing list with its command line tool.

    FYI: https://docs.iredmail.org/integration.m … -line-tool

    artavec wrote:

    I am slowly discovering what is included!  I am disappointed that the groupware component does not include some kind of forum or bulletin board. But first I need to discover how to add a user to it, then I will explore the options further.

    i don't get why groupware should offer a forum or bulletin board ...


    0 0
  • 12/20/18--02:51: Re: Can't send receive mail
  • Try to restart "rsyslog" service.

    On Debian/Ubuntu system, /var/log/syslog and /var/log/mail.log are present after system installation, i don't understand why your server doesn't have it.


    0 0
  • 12/20/18--03:31: SOGo Login Error
  • ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.9 MYSQL edition.
    - Deployed with iRedMail Easy or the downloadable installer? Downloadable Installer
    - Linux/BSD distribution name and version: FreeBSD 11.2 64bit
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro? No
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====
    Hi

    Today. I migrated old iRedmail Server (no SOGo) to new server (clean install, latest iRedMail). I transported vmail and roundcube tables to new server. But there are strange events on the server. SOGo is not working. Always giving Wrong username and password. error. But evertyhing works fine with Roundcube. Mail send and receive working. When I realize that SOGO doesn't work.I restarted nginx. But after that iredadmin page giving 502 Bad Gateway error. So iredadmin and SOGo not working anymore. I never changed any configuration on new server.

    sogo.log
    [ERROR] [we-rm] did not find locale for language: Turkish
    SOGoRootPage Login from '172.25.1.10' for user 'user@hidingdomain' might not have worked - password policy: 65535  grace: -1  expire: -1  bound: 0

    nginx/error.log
    2018/12/20 14:08:48 [error] 6297#100490: *116 kevent() reported that connect() failed (61: Connection refused) while connecting to upstream, client: 172.25.1.10, server: _, request: "GET /iredadmin HTTP/1.1", upstream: "uwsgi://127.0.0.1:7791", host: "mail.hidingdomain"

    How can i fix erros? Am i missing something?

    Best Regards.

    Hasan Alp İNAN


    0 0

    ZhangHuangbin wrote:

    Patch for iRedAdmin-Pro-SQL-3.0 AND iRedAdmin-Pro-LDAP-3.2:
    https://pastebin.com/raw/KVAuDm4k

    if you're not familiar with patch, feel free to contact me (zhb _at_ iredmail _dot_ org) to get a patched version.


       Hello,

    Thanks for the fast fix. It's working.


    0 0
  • 12/20/18--03:52: Re: SOGo Login Error
  • Hi

    I found a tool in iredadmin setup folder. migrate_sql_alias_table.py what is it for?  Also postmaster@ user successfully login to SOGo but migrated users not.


    0 0
  • 12/20/18--05:11: Re: Can't send receive mail
  • It is an amazon ubuntu 64.
    Have installed rsyslog and now I have CRON.log  amavis.log  dovecot.log  php-fpm.log  postfix.log  rsyslogd.log  sudo.log  systemd-timesyncd.log  systemd.log

    In postfix.log Iget this when sending mail:
    2018-12-20T12:59:25.655207+00:00 mail postfix/error[13435]: 43KTw66W1tz2806: to=<ulf@ulferik.com>, relay=none, delay=99351, delays=99351/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to rab.ulferiksplace.com[34.251.234.152]:25: Connection timed out)

    Can you get anything out of this?

    ZhangHuangbin wrote:

    Try to restart "rsyslog" service.

    On Debian/Ubuntu system, /var/log/syslog and /var/log/mail.log are present after system installation, i don't understand why your server doesn't have it.


    0 0

    ZhangHuangbin wrote:

    Patch for iRedAdmin-Pro-SQL-3.0 AND iRedAdmin-Pro-LDAP-3.2:
    https://pastebin.com/raw/KVAuDm4k

    if you're not familiar with patch, feel free to contact me (zhb _at_ iredmail _dot_ org) to get a patched version.

    Yes, I can also confirm that this latest version is now working. Thanks.


    0 0
  • 12/20/18--05:21: Re: Can't send receive mail
  • I have /var/log/mail/CRON.log  amavis.log  dovecot.log  php-fpm.log  postfix.log  rsyslogd.log  sudo.log  systemd-timesyncd.log  systemd.log


    0 0

    so question; you mention iredadmin becoming its own service but you don't instruct on removing / disabling uwsgi. why?

    also, you never mention or link to your guide on updating netdata to current binary package version.

    when i downloaded iredadmin, there was a newer version on your repo then is mentioned here. should we use the newer one or what's mentioned here?

    that's all i have. thanks.


    0 0

    one more thing....
    I had tested your proposal and is ok but i want to add an header in mail to know the real sernder.
    Example:
    user1@domain.my,user2@domain.my,user3@domain.my have permission to shared@domain.my
    When user1 send email as shared i want that in header there is Sender: user1 ( or something similar).

    Thanks in advance


    0 0

    also, you mention, "Set file/directory permission to 0400 for dumpped SQL backup files". where is this accomplished in your upgrade tutorial?

    and this, "Switch to utf8mb4 as default character set in MySQL", ?

    anything else i've missed?


    0 0
  • 12/20/18--15:34: Problem Relay
  • ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.9
    - Deployed with iRedMail Easy or the downloadable installer?
    - Linux/BSD distribution name and version: Debian
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro?
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    I installed a new server with iRedMail 0.9.9. I need to relay from a VPS using the new mail server. With version 0.9.8 it has always worked now no more. This is the log

    Dec 21 00:20:46 vps postfix/master[7020]: daemon started -- version 3.1.8, configuration /etc/postfix
    Dec 21 00:20:46 vps postfix/qmgr[7022]: 2C38E5FB9F: from=<www-data@myserver.com>, size=347, nrcpt=1 (queue active)
    Dec 21 00:20:46 vps postfix/qmgr[7022]: C61F25FBA1: from=<vps@myserver.com>, size=339, nrcpt=1 (queue active)
    Dec 21 00:20:46 vps postfix/qmgr[7022]: D08B45FBA5: from=<vps@myserver.com>, size=350, nrcpt=1 (queue active)
    Dec 21 00:20:46 vps postfix/qmgr[7022]: E76965FBA0: from=<vps@myserver.com>, size=342, nrcpt=1 (queue active)
    Dec 21 00:20:46 vps postfix/smtp[7026]: connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connection refused
    Dec 21 00:20:46 vps postfix/smtp[7028]: connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connection refused
    Dec 21 00:20:46 vps postfix/smtp[7026]: 2C38E5FB9F: to=<vincenzo@myserver.it>, relay=none, delay=1553, delays=1553/0.06/0.02/0, dsn=4.4.1, status=deferred (connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connectio$
    Dec 21 00:20:46 vps postfix/smtp[7028]: C61F25FBA1: to=<vinacc@gmail.com>, relay=none, delay=1526, delays=1526/0.07/0.02/0, dsn=4.4.1, status=deferred (connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connection r$
    Dec 21 00:20:46 vps postfix/smtp[7026]: connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connection refused
    Dec 21 00:20:46 vps postfix/smtp[7028]: connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connection refused
    Dec 21 00:20:46 vps postfix/smtp[7026]: D08B45FBA5: to=<vincenzo@myserver.it>, relay=none, delay=316, delays=316/0.09/0.02/0, dsn=4.4.1, status=deferred (connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connection $
    Dec 21 00:20:46 vps postfix/smtp[7028]: E76965FBA0: to=<vincenzo@myserver.it>, relay=none, delay=1536, delays=1536/0.1/0.01/0, dsn=4.4.1, status=deferred (connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connection$
    Dec 21 00:20:48 vps postfix/pickup[7021]: CF96F5FBA2: uid=0 from=<vps@myserver.com>
    Dec 21 00:20:48 vps postfix/cleanup[7039]: CF96F5FBA2: message-id=<20181220232048.CF96F5FBA2@vps.myserver.com>
    Dec 21 00:20:48 vps postfix/qmgr[7022]: CF96F5FBA2: from=<vps@myserver.com>, size=350, nrcpt=1 (queue active)
    Dec 21 00:20:48 vps postfix/error[7040]: CF96F5FBA2: to=<vincenzo@myserver.it>, relay=none, delay=0.03, delays=0.02/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to mail.myserver.com[$
    Dec 21 00:21:51 vps postfix/pickup[7021]: 6ACA05FBA7: uid=33 from=<www-data>
    Dec 21 00:21:51 vps postfix/cleanup[7039]: 6ACA05FBA7: message-id=<0i9mxki7lx@api.test.com>
    Dec 21 00:21:51 vps postfix/qmgr[7022]: 6ACA05FBA7: from=<www-data@vps.myserver.com>, size=27707, nrcpt=1 (queue active)

    What could be the problem?


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.9
    - Deployed with iRedMail Easy or the downloadable installer? no
    - Linux/BSD distribution name and version:  Ubuntu 16.04 LTS
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): mariadb
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro? no
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    hello,

    When accessing /mail np.
    When accessing /iredadmin get that error.

    services running:
    nginx
    php7.0-fpm
    uwsgi
    nginx.log file:

    2018/12/20 16:27:10 [error] 1300#1300: *23 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.10.15, server: _, request: "GET /iredadmin HTTP/1.1", upstream:$
    2018/12/20 18:01:03 [error] 1300#1300: *27 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.10.15, server: _, request: "GET /iredadmin HTTP/1.1", upstream:$
    2018/12/20 18:01:05 [error] 1300#1300: *27 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.10.15, server: _, request: "GET /iredadmin HTTP/1.1", upstream:$
    2018/12/20 18:09:01 [error] 1300#1300: *48 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.10.15, server: _, request: "GET /iredadmin HTTP/1.1", upstream:$
    2018/12/20 18:09:02 [error] 1300#1300: *48 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.10.15, server: _, request: "GET /iredadmin HTTP/1.1", upstream:$
    2018/12/20 18:09:13 [error] 1300#1300: *48 connect() failed (111: Connection refused) while connecting to upstream, client: 192.168.10.15, server: _, request: "GET /iredadmin HTTP/1.1", upstream:$

    Thanks/ Yigal


    0 0
  • 12/21/18--02:34: Support for Exchange 2019
  • ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): v0.9.1 mySQL
    - Deployed with iRedMail Easy or the downloadable installer?: No
    - Linux/BSD distribution name and version: Ubuntu 18.04
    - Web server (Apache or Nginx): Nginx

    1.1.1.1 - - [21/Dec/2018:11:31:23 +0100] "GET /autodiscover/autodiscover.json?Email=username%40domain&Protocol=Autodiscoverv1&RedirectCount=1 HTTP/1.1" 404 162 "-" "Microsoft Office/16.0 (Windows NT 10.0; Microsoft Outlook 16.0.10339; Pro)"
    1.1.1.1 - - [21/Dec/2018:11:31:23 +0100] "POST /autodiscover/autodiscover.xml HTTP/1.1" 404 162 "-" "Microsoft Office/16.0 (Windows NT 10.0; Microsoft Outlook 16.0.10339; Pro)"
    1.1.1.1 - - [21/Dec/2018:11:31:23 +0100] "GET /autodiscover/autodiscover.xml HTTP/1.1" 301 178 "-" "Microsoft Office/16.0 (Windows NT 10.0; Microsoft Outlook 16.0.10339; Pro)"
    1.1.1.1 - - [21/Dec/2018:11:31:23 +0100] "POST /autodiscover/autodiscover.xml HTTP/1.1" 404 162 "-" "Microsoft Office/16.0 (Windows NT 10.0; Microsoft Outlook 16.0.10339; Pro)"

    ====

    Hi,
    It does not seems like Outlook 2019 is capable of adding a custom ActiveSync compatible server anymore. So I have to change the webbserver configuration in order to be able to work with Autodiscover.
    The logs above shows the requests - so how do we change the nginx config in order to make it work?

    Thanks!


    0 0

    fsantiago06111979 wrote:

    so question; you mention iredadmin becoming its own service but you don't instruct on removing / disabling uwsgi. why?

    This is handled by iRedAdmin(-Pro) upgrade script automatically.

    fsantiago06111979 wrote:

    also, you never mention or link to your guide on updating netdata to current binary package version.

    Updated the iRedMail upgrade tutorial, and here's the tutorial to upgrade netdata: https://docs.iredmail.org/upgrade.netdata.html

    fsantiago06111979 wrote:

    when i downloaded iredadmin, there was a newer version on your repo then is mentioned here. should we use the newer one or what's mentioned here?

    Use the latest one (till now it's iRedAdmin-0.9.3).

    fsantiago06111979 wrote:

    also, you mention, "Set file/directory permission to 0400 for dumpped SQL backup files". where is this accomplished in your upgrade tutorial?

    Updated iRedMail upgrade tutorial to mention this.

    fsantiago06111979 wrote:

    and this, "Switch to utf8mb4 as default character set in MySQL", ?

    No changes required for existing SQL databases.

    If you need to create a new database, you're free to choose a proper character set, but for databases like "vmail", "roundcubemail", it's created in utf8mb4 by iRedMail now.


    0 0

    selea wrote:

    /autodiscover/autodiscover.json?Email=username%40domain&Protocol=Autodiscoverv1&RedirectCount=1

    Hmm, seems it requests a new URL. Old Outlook versions use "/autodiscover/autodiscover.xml".

    Need some time to work it out.


    0 0

    Is "iredadmin" service running?

    iRedAdmin (and iRedAdmin-Pro) is now running as a standalone service named "iredadmin". Please try to restart it then try again.


    0 0
  • 12/21/18--07:38: Re: Problem Relay
  • vinacc wrote:

    Dec 21 00:20:46 vps postfix/smtp[7028]: connect to mail.myserver.com[XXX.XXX.XXX.XXX]:587: Connection refused

    Is your IP blocked on iRedMail server? Try to stop "fail2ban" service then try again.


    0 0
  • 12/21/18--07:39: Re: Can't send receive mail
  • ulferik wrote:

    2018-12-20T12:59:25.655207+00:00 mail postfix/error[13435]: 43KTw66W1tz2806: to=<ulf@ulferik.com>, relay=none, delay=99351, delays=99351/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to rab.ulferiksplace.com[34.251.234.152]:25: Connection timed out)

    - Amazon EC2 blocks port 25 by default, you need to contact Amazon support and ask them to unblock port 25.
    - Also double check the EC2 firewall (managed in your Amazon AWS console), make sure it doesn't block port 25.


    0 0

    Thanks for the feedback. smile


older | 1 | .... | 1373 | 1374 | (Page 1375) | 1376 | 1377 | .... | 1394 | newer