Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

The most recent posts in iRedMail.

older | 1 | .... | 1384 | 1385 | (Page 1386) | 1387 | 1388 | .... | 1394 | newer

    0 0

    I'm afraid that i'm lost, i didn't understand what the issue is sad


    0 0

    Please check /var/log/maillog (Postfix log) and /var/log/dovecot/*.log (Dovecot).


    0 0

    Please use iRedAPD-2.4.


    0 0

    nikos.frangakis wrote:

    Hi, i get the same "not found" error, when pressing the button "Send me email with download link".
    iRedAdmin-Pro-SQL 3.1 (You are running version 3.0)

    Sent. Sorry about this trouble.


    0 0

    FMB wrote:

    So do I (iRedAdmin-Pro-LDAP 3.2).

    Sent.


    0 0

    Waschl wrote:

    Same Problem here...

    Sent.


    0 0

    derrickr wrote:

    To test IF the install and iRedAPD are working as expected.

    You can check its log file: /var/log/iredapd/iredapd.log.
    If you need more details, turn on debug mode and check log file. FYI: https://docs.iredmail.org/debug.iredapd.html


    0 0

    Patatedouce wrote:

    The query inside the /etc/sogo/sogo.conf is like that:

    What's the ldap filter?


    0 0

    ZhangHuangbin wrote:

    I'm afraid that i'm lost, i didn't understand what the issue is sad

    Thanks for looking at this - I don't think I've explained it very well.

    I can't see anything odd in my setup and the postfix help files haven't helped me yet. I also haven't been able to replicate my problem using test (i.e. non-client) emails. My client knows that there is some sort of internal domain leakage at their end and are looking at it.

    Let's close this question for now and, if I get any insights, I'll share.

    Martin


    0 0
  • 01/06/19--05:04: Cannot receive email
  • ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version: 0.9.9 MYSQL edition.
    - Deployed with the downloadable installer.
    - Linux/BSD distribution name and version: Ubuntu 16.04 LTS
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro?: Nope
    ====

    So basically I setup the server with the installer and the logs don't show any issues. I created a new user and sending mail works fine. However receiving email fails. The /var/log/mail.log shows me the following error:

    to=<postmaster@MYDOMAIN.COM>, relay=dovecot, delay=1478, delays=1478/0/0/0.04, dsn=4.3.0, status=deferred (temporary failure. Command output: lda(postmaster@MYDOMAIN.COM,)Error: Error reading configuration: Invalid settings: postmaster_address setting not given lda: Fatal: Internal error occurred. Refer to server log for more information. )


    I tried searching the forums and the rest of the internet but I cannot find a working solution. Anyone with tips?


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.9
    - Deployed with iRedMail Easy or the downloadable installer? download
    - Linux/BSD distribution name and version: FreeBSD
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
    - Web server (Apache or Nginx): Apache
    - Manage mail accounts with iRedAdmin-Pro? Yes 3.1
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    Im getting these errors after upgrading. What to do?

    /usr/local/bin/python /opt/iredapd/tools/cleanup_db.py >/dev/null:

    Traceback (most recent call last):
    File "/opt/iredapd/tools/cleanup_db.py", line 47, in <module>
    conn_iredapd.delete('greylisting_tracking', where='record_expired < %d' % now)
    File "/usr/local/lib/python2.7/site-packages/web/db.py", line 942, in delete
    self.ctx.commit()
    File "/usr/local/lib/python2.7/site-packages/web/db.py", line 553, in commit
    ctx.db.commit()
    _mysql_exceptions.OperationalError: (2013, 'Lost connection to MySQL server during query')


    /usr/local/bin/python /usr/local/www/iredadmin/tools/delete_mailboxes.py:

    Traceback (most recent call last):
    File "/usr/local/www/iredadmin/tools/delete_mailboxes.py", line 162, in <module>
    qr = conn.select('deleted_mailboxes', where=sql_where)
    File "/usr/local/lib/python2.7/site-packages/web/db.py", line 719, in select
    return self.query(qout, processed=True)
    File "/usr/local/lib/python2.7/site-packages/web/db.py", line 678, in query
    db_cursor = self._db_cursor()
    File "/usr/local/lib/python2.7/site-packages/web/db.py", line 590, in _db_cursor
    return self.ctx.db.cursor()
    File "/usr/local/lib/python2.7/site-packages/web/db.py", line 531, in _getctx
    self._load_context(self._ctx)
    File "/usr/local/lib/python2.7/site-packages/web/db.py", line 542, in _load_context
    ctx.db = self._connect(self.keywords)
    File "/usr/local/lib/python2.7/site-packages/web/db.py", line 570, in _connect
    return self.db_module.connect(**keywords)
    File "/usr/local/lib/python2.7/site-packages/MySQLdb/__init__.py", line 81, in Connect
    return Connection(*args, **kwargs)
    File "/usr/local/lib/python2.7/site-packages/MySQLdb/connections.py", line 193, in __init__
    super(Connection, self).__init__(*args, **kwargs2)
    _mysql_exceptions.OperationalError: (2026, 'SSL connection error: error:00000001:lib(0):func(0):reason(1)')


    0 0

    ZhangHuangbin wrote:
    artavec wrote:

    because nginx will not serve any css to other sites I set up on the server.

    This doesn't make any sense, Nginx should work fine in this case. Did you get any error message of this issue?

    Bizarrely no error messages, and nothing at all logged that I could find. All css was just silently dropped.  I thought the firewall might be blocking it somehow, but that did not make sense as it would go via the same port. 

    Never mind, I lost patience and transferred all the http activity to another cloud server, which I coincidentally had recently reimaged and set up with nginx.  It works fine there, so I will let the two servers remain specialist, one for mail and one for 3w.

    It has to be something I misconfigured, but sometimes life is too short to solve all the silly problems...


    0 0

    thanks for ur guide mate
    here is my logs
    would you please check it?
    http://www.doctorgorji.com/logs.rar
    thanks in advancs


    0 0
  • 01/06/19--20:45: Re: Cannot receive email
  • Comment out or remove "postmaster_address =" in /etc/dovecot/dovecot.conf, restart Dovecot service and try again.


    0 0

    - Did you get them frequently, or just once, or few times a day?
    - Any error if you run the commands manually?


    0 0

    artavec wrote:

    Bizarrely no error messages, and nothing at all logged that I could find. All css was just silently dropped.  I thought the firewall might be blocking it somehow, but that did not make sense as it would go via the same port. 

    - Does your web browser report "404 not found" error for these CSS files?
    - Does Nginx log these "404 not found" error in its log file when you access the website? If no, then probably your firewall or some network device blocks the requests and it doesn't reach Nginx at all. In this case, no matter Apache/Nginx you use, you get same issue.


    0 0

    Try to read the log lines one by one by yourself. smile


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release):
    - Deployed with iRedMail Easy or the downloadable installer?
    - Linux/BSD distribution name and version:
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL):
    - Web server (Apache or Nginx):
    - Manage mail accounts with iRedAdmin-Pro?
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    i have just installed iredmail in fresh ubuntu server. Everything works perfect sending and receiving mail is working perfect.
    > But now i need to use that in wordpress smtp setting. I configure smtp setting in wordpress using port 587, TLS and hosname mx.domain.com and when i send mail it says error connect smtp host.
    > Can you help i think the server is not using smtp to send mail?
    or is there any SSL certificate issue?


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.8 MARIADB edition
    - Deployed with iRedMail Easy or the downloadable installer?: downloadable installer
    - Linux/BSD distribution name and version: Ubuntu Server 18.04.1 LTS (GNU/Linux 4.15.0-43-generic x86_64)
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): MariaDb (unsure)
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro?: no
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====
    Hi,

    i have a question regarding sieve. I want to filter all messages, where the envelope sender and the header sender differ. For this i want to check, whether the header sender contains the mail address of the envelope sender. But my attempts fail. How can i do that sieve?


    0 0
  • 01/06/19--22:04: Re: Cannot receive email
  • ZhangHuangbin wrote:

    Comment out or remove "postmaster_address =" in /etc/dovecot/dovecot.conf, restart Dovecot service and try again.

    Thank you for the response ZhangHuangbin. I've seen the same suggestion on the forum before and can assure you that my config does not contain the "postmaster_address = " line.

    Do you have any other suggestions? Or could you maby explain why the line is not supposed to be there since the error states it should be?


older | 1 | .... | 1384 | 1385 | (Page 1386) | 1387 | 1388 | .... | 1394 | newer