Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

The most recent posts in iRedMail.

older | 1 | .... | 1345 | 1346 | (Page 1347) | 1348 | 1349 | .... | 1394 | newer

    0 0
  • 11/11/18--19:51: Re: MX Backup issue
  • ZhangHuangbin wrote:
    MattHo wrote:

    We have 2 x iRedmail Servers which installed iRedAdmin-Pro, we are planning to relocated these 2 servers to another location.

    Just a quick check, do you have 2 iRedAdmin-Pro licenses for these 2 servers?

    Yes, both servers have valid iRedAdmin-Pro licenses.

    ZhangHuangbin wrote:
    MattHo wrote:

    Could we create 1 x iRedmail Server with iRedAdmin only as a Backup MX to provide MX backup services for these 2 servers while relocating?

    Sure.

    Good

    ZhangHuangbin wrote:
    MattHo wrote:

    The domains in MX Backup Server I should point to new IP right?
    Domain A point to 10.10.10.10
    Domain B point to 20.20.20.20

    I'm afraid that i don't quite understand what this means. sad

    1 MX backup server can backup multiple domains with different primary mx server IPs?

    ZhangHuangbin wrote:
    MattHo wrote:

    And which firewall port I need to open for the MX Backup Server?

    Just port 25 should be fine (for backup mx service).

    Thanks a lot.


    0 0
  • 11/11/18--20:57: Re: iRedMail-0.9.8
  • ZhangHuangbin wrote:

    You need to tweak your SQL query to return the SQL columns/values you want. I'm not sure what i can help.

    To help with SQL. How the columns should look like.
    Currently my SQL is:
    CREATE VIEW sogo.users (c_uid, c_name, c_password, c_cn, mail, domain) AS SELECT username, username, password, name, username, domain FROM vmail.mailbox WHERE enablesogo=1 AND active=1;


    Please advise which column names and values I should create/adjust in order to see multiple aliases selection (sender) in new message


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.8 PGSQL Release
    - Linux/BSD distribution name and version: Ubuntu 18.04 LTS
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): PGSQL
    - Web server (Apache or Nginx):Nginx
    - Manage mail accounts with iRedAdmin-Pro? Yes
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    Hello,

    I check the log of fail2ban and I saw this line :
    6-INFO Nov 12 06:44:15 mail fail2ban-server[131749]:  Found no accessible config files for 'filter.d/sshd-ddos' under /etc/fail2ban #
    6-INFO Nov 12 06:44:15 mail fail2ban-server[131749]:  Errors in jail 'sshd-ddos'. Skipping... #
    And in fact this file does not exit so fail2ban is not running for sshd-ddos

    root@mail:/etc/fail2ban# fail2ban-client status
    Status
    |- Number of jail:      6
    `- Jail list:   dovecot-iredmail, nginx-http-auth, postfix-iredmail, postfix-pregreet-iredmail, roundcube-iredmail, sshd

    Is it normal ? Where could I find this conf file ?

    Thanks

    Patrick

    (Attached file jail.conf and jail.local and only change parameters in jail.local


    0 0

    You could try to set
    smtpd_sender_restrictions = ...
    and add/modify the contents of
    check_sender_access pcre:/etc/postfix/sender_access.pcre

    See http://postfix.cs.utah.edu/postconf.5.h … strictions
    and
    http://postfix.cs.utah.edu/access.5.html

    user@  Matches all mail addresses with the specified  user
                  part.


    0 0
  • 11/12/18--03:23: Re: mlmmj + DMARC + rejects
  • Oops. Done.


    0 0

    On my server I can find:

    [root@mail2 jail.d]# pwd
    /etc/fail2ban/jail.d
    [root@mail2 jail.d]# ls -l
    total 44
    -rw-r--r-- 1 root root 270 Jul 13  2017 00-firewalld.conf
    -rw-r--r-- 1 root root 221 Nov  8  2017 apache-auth.local
    -rw-r--r-- 1 root root 321 Jul  5  2017 dovecot.local
    -rw-r--r-- 1 root root 228 Feb 20  2018 nginx-http-auth.local
    -rw-r--r-- 1 root root 206 Apr 12  2018 postfix-pregreet.local
    -rw-r--r-- 1 root root 216 Jul  5  2017 postfix-sasl.local
    -rw-r--r-- 1 root root 224 Jul  5  2017 postfix.local
    -rw-r--r-- 1 root root 249 Jul  5  2017 roundcube.local
    -rw-r--r-- 1 root root 217 Jul  5  2017 sogo.local
    -rw-r--r-- 1 root root 159 Jul  5  2017 sshd-ddos.local
    -rw-r--r-- 1 root root 144 Jul  5  2017 sshd.local

    In the /etc/fail2ban/jail.conf I find:

    [sshd-ddos]
    # This jail corresponds to the standard configuration in Fail2ban.
    # The mail-whois action send a notification e-mail with a whois request
    # in the body.
    port    = ssh
    logpath = %(sshd_log)s
    backend = %(sshd_backend)s

    and in  /etc/fail2ban/jail.d/sshd-ddos.local

    [sshd-ddos]
    enabled     = true
    filter      = sshd-ddos
    action      = iptables-multiport[name=sshd-ddos, port="22", protocol=tcp]
    logpath     = /var/log/secure


    0 0
  • 11/12/18--05:18: Huge CPU usage
  • ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.8 MARIADB edition
    - Linux/BSD distribution name and version: CentOS Linux release 7.5.1804 (Core)
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro? No
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    Hi to all,

    recently on my server I noticed a big slowdown of the web part as well as via SSH.
    That server is a VPS over KVM OpenStack with 1 vCore at 2,4  GHz, 2 GB of RAM and 20 GB SS over RAID.
    I checked today and it turns out that the CPU is always 100% with a load avarage of 7.76 9.91 10.14 at this time.
    I've restarted the machine and done some checks and there seems to be some problem.

    Here a screenshot from HTOP :

    https://i.postimg.cc/t7Fr0wrK/Capture.jpg

    I've check the process usage i see that :

    [root@srv-main ~]# ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%cpu | head
      PID  PPID CMD                         %MEM %CPU
     1536  1460 ps -eo pid,ppid,cmd,%mem,%c  0.0 17.0
      500     1 /usr/bin/python -Es /usr/sb  1.5  7.6
     1484   856 /usr/bin/python2 -s /usr/bi  0.5  7.3
     1462   943 /usr/libexec/mysqld --based  4.1  7.2
     1330     1 /usr/bin/perl -T /usr/sbin/  0.5  6.7
     1333     1 /usr/sbin/clamd -c /etc/cla  0.9  6.7
     1290  1266 gzip -cd -- /boot/initramfs  0.0  6.2
      856     1 /usr/bin/python2 -s /usr/bi  0.6  4.2
        1     0 /usr/lib/systemd/systemd --  0.2  3.1
    
    [root@srv-main etc]# ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%mem | head
      PID  PPID CMD                         %MEM %CPU
     1478   963 /usr/libexec/mysqld --based  6.1  1.7
     4331     1 /usr/sbin/clamd -c /etc/cla  5.0 45.5
     1056   878 php-fpm: pool www            3.2  0.3
     1051   878 php-fpm: pool www            3.2  0.3
     1059   878 php-fpm: pool www            3.2  0.3
     1046   878 php-fpm: pool www            1.8  0.3
      504     1 /usr/bin/python -Es /usr/sb  1.5  0.2
     1441     1 /opt/netdata/bin/srv/netdat  1.4  0.8
      505   491 /usr/sbin/uwsgi --ini ireda  1.1  0.4

    The version of amavisd-new is :

    [root@srv-main run]# rpm -qi amavisd-new
    Name        : amavisd-new
    Version     : 2.11.1
    Release     : 1.el7
    Architecture: noarch
    Install Date: Mon 12 Nov 2018 12:00:10 PM CET
    Group       : Applications/System
    Size        : 3318497
    License     : GPLv2+ and BSD and GFDL
    Signature   : RSA/SHA256, Thu 18 Oct 2018 04:03:17 PM CEST, Key ID 6a2faea2352c64e5
    Source RPM  : amavisd-new-2.11.1-1.el7.src.rpm
    Build Date  : Thu 18 Oct 2018 03:03:47 PM CEST
    Build Host  : buildvm-20.phx2.fedoraproject.org
    Relocations : (not relocatable)
    Packager    : Fedora Project
    Vendor      : Fedora Project
    URL         : [url]https://amavis.org/[/url]
    Bug URL     : [url]https://bugz.fedoraproject.org/amavisd-new[/url]
    Summary     : Email filter with virus scanner and spamassassin support
    Description :
    amavisd-new is a high-performance and reliable interface between mailer
    (MTA) and one or more content checkers: virus scanners, and/or
    Mail::SpamAssassin Perl module. It is written in Perl, assuring high
    reliability, portability and maintainability. It talks to MTA via (E)SMTP
    or LMTP, or by using helper programs. No timing gaps exist in the design
    which could cause a mail loss.

    From /var/log/messages i see the following error message with taile -f messages :

    Nov 12 13:38:05 srv-main systemd: amavisd.service start operation timed out. Terminating.
    Nov 12 13:38:06 srv-main systemd: Failed to start Amavisd-new is an interface between MTA and content checkers..
    Nov 12 13:38:06 srv-main systemd: Unit amavisd.service entered failed state.
    Nov 12 13:38:06 srv-main systemd: amavisd.service failed.
    Nov 12 13:38:07 srv-main systemd: amavisd.service holdoff time over, scheduling restart.
    Nov 12 13:38:07 srv-main systemd: clamd@amavisd.service start operation timed out. Terminating.
    Nov 12 13:38:08 srv-main systemd: Starting Amavisd-new is an interface between MTA and content checkers....
    Nov 12 13:38:08 srv-main systemd: Failed to start clamd scanner (amavisd) daemon.
    Nov 12 13:38:08 srv-main systemd: Unit clamd@amavisd.service entered failed state.
    Nov 12 13:38:08 srv-main systemd: clamd@amavisd.service failed.
    Nov 12 13:38:08 srv-main systemd: clamd@amavisd.service holdoff time over, scheduling restart.
    Nov 12 13:38:09 srv-main systemd: Starting clamd scanner (amavisd) daemon...
    Nov 12 13:38:10 srv-main clamd: WARNING: Ignoring deprecated option AllowSupplementaryGroups at line 21

    I load amavisd in debug mode too, after stop the service with the following command : amavisd -u amavis -c /etc/amavisd/amavisd.conf debug and attach the output to this topic.

    Can someone help me out of this issue ?

    Thanks again for your assist and regards.

    LainX84


    0 0
  • 11/12/18--05:36: Re: SPAM Question
  • ZhangHuangbin wrote:

    - You may need to turn on debug mode in iRedAPD, so that we can get more details about (new) spam email.

    Ok, I have enabled debug mode for iRedAPD. WHen a new spam email comes in, I'll post the log contents.


    0 0

    ZhangHuangbin wrote:

    Its license is not good for us to integrate and redistribute it.

    Hasn't rainloops license changed to AGPL for the community version -- which mostly lacks autoupdate features which you wouldn't use anyway.   We could probably work out how to make it work -- but I'd love to see a cookbook / plan for rainloop iredmail integration.


    0 0

    ZhangHuangbin wrote:

    I'm afraid that we need a new smtp port for SOGo in this case, but with default iRedMail settings, it works fine.

    *) Add new lines in /etc/postfix/master.cf:

    127.0.0.1:2525    inet  n       -       n       -       -       smtpd
        -o syslog_name=postfix/plain-smtp-2525
        -o smtpd_sasl_auth_enable=yes
        -o smtpd_tls_security_level=may
        -o smtpd_client_restrictions=permit_sasl_authenticated,reject
        -o content_filter=smtp-amavis:[127.0.0.1]:10026

    *) In /etc/sogo/sogo.conf, update "SOGoSMTPServer" setting:

        SOGoSMTPServer = 127.0.0.1:2525;

    *) Restart both postfix and sogo services.


    I was able to resolve the issue - It was discovered that someone had followed this doc:
    https://docs.iredmail.org/allow.insecur … tions.html

    Section: Allow insecure SMTP connection on port 25

    Once I undid these changes I was able to send mail from iOS again. I believe that your solution above would have also resolved the issue. The changes to port 25 were done while testing a multifunction device, but it was ultimately not used. The changes were never backed out.

    Thank you for all the help on this!


    0 0

    Below is a log entry for one of the missing emails which shows it was delivered to the mailbox, but going into the mail box and also into the directory structure you will find no email at all. I have gone through all the logs i can find for this one date/time and found not a single error which is extremely puzzling.

    On Friday I deleted the user account and recreated the account while preserving the old email directory to see if the issue might be resolved that way.


    MAIL LOG:
    Oct 30 09:15:44 mx postfix/postscreen[30558]: PASS OLD [209.85.161.97]:33909
    Oct 30 09:15:44 mx postfix/smtpd[30559]: connect from mail-yw1-f97.google.com[209.85.161.97]
    Oct 30 09:15:45 mx postfix/smtpd[30559]: 8E3F78163E07: client=mail-yw1-f97.google.com[209.85.161.97]
    Oct 30 09:15:45 mx postfix/cleanup[30779]: 8E3F78163E07: message-id=<06E242923803464881F2AF448A38C59901152FF580@Legend-Mail.legend.local>
    Oct 30 09:15:45 mx postfix/qmgr[1694]: 8E3F78163E07: from=<tericXXXX@XXXXXXX.XXX>, size=5599, nrcpt=1 (queue active)
    Oct 30 09:15:45 mx postfix/smtpd[30559]: disconnect from mail-yw1-f97.google.com[209.85.161.97]
    Oct 30 09:15:45 mx postfix/smtpd[30791]: connect from mx.XXXX.XXX[127.0.0.1]
    Oct 30 09:15:45 mx postfix/smtpd[30791]: F04A48163E08: client=mx.XXXX.XXX[127.0.0.1]
    Oct 30 09:15:45 mx postfix/cleanup[30779]: F04A48163E08: message-id=<06E242923803464881F2AF448A38C59901152FF580@Legend-Mail.legend.local>
    Oct 30 09:15:46 mx postfix/smtpd[30791]: disconnect from mx.XXXX.XXX[127.0.0.1]
    Oct 30 09:15:46 mx postfix/qmgr[1694]: F04A48163E08: from=<tericXXXX@XXXXXXXX.XXX>, size=6442, nrcpt=1 (queue active)
    Oct 30 09:15:46 mx amavis[27906]: (27906-20) Passed CLEAN {RelayedInbound}, [209.85.161.97]:33909 [209.201.111.85] <tericXXXX@XXXXXXXX.XXX> -> <schedule@XXXXXX.XXX>, Queue-ID: 8E3F78163E07, Message-ID: <06E242923803464881F2AF448A38C59901152FF580@legend-mail.legend.local>, mail_id: YYUKxUboxfhV, Hits: -, size: 5599, queued_as: F04A48163E08, dkim_sd=20150623:XXXXXXXXXXX.20150623.gappssmtp.com, 348 ms
    Oct 30 09:15:46 mx postfix/smtp[30788]: 8E3F78163E07: to=<schedule@XXXXXXX.XXX>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.52, delays=0.15/0/0/0.36, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as F04A48163E08)
    Oct 30 09:15:46 mx postfix/qmgr[1694]: 8E3F78163E07: removed
    Oct 30 09:15:46 mx postfix/pipe[30898]: F04A48163E08: to=<schedule@XXXXXXXX.XXX>, relay=dovecot, delay=0.3, delays=0.03/0/0/0.27, dsn=2.0.0, status=sent (delivered via dovecot service)
    Oct 30 09:15:46 mx postfix/qmgr[1694]: F04A48163E08: removed


    SIEVE LOG:
    Oct 30 09:15:46 lda(schedule@XXXXXXX.XXX): Info: sieve: msgid=<06E242923803464881F2AF448A38C59901152FF580@Legend-Mail.legend.local>: stored mail into mailbox 'INBOX'

    IREDAPD LOG:
    2018-10-30 09:15:45 INFO [209.85.161.97] RCPT, tericXXX@XXXXX.XXX -> schedule@XXXXXX.XXX, OK wblist=(10, 3, 'W') [sasl_username=, sender=tericXXX@XXXXXXX.XXX, client_name=mail-yw1-f97.google.com, reverse_client_name=mail-yw1-f97.google.com, helo=mail-yw1-f97.google.com, encryption_protocol=TLSv1.2, process_time=0.0067s]
    2018-10-30 09:15:45 INFO [209.85.161.97] END-OF-MESSAGE, tericXXXX@XXXXXXX.XXX -> schedule@XXXXXXX.XXX, DUNNO [recipient_count=1, size=5424, process_time=0.0021s]
    2018-10-30 09:17:21 INFO Whitelisted: wblist=(10, 3855, 'W')


    Thank you for your time and help
    Justin


    0 0

    ok fair enough.


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.8
    - Linux/BSD distribution name and version: CentOS 7
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro? iRedAdmin Pro 3.1
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====
    /var/log/nginx/error.log
    2018/11/13 10:00:59 [error] 426#0: *58 upstream prematurely closed connection while reading response header from upstream, client: 10.52.0.52, server: _, request: "GET /iredadmin HTTP/1.1", upstream: "uwsgi://unix:/run/uwsgi/iredadmin.socket:", host: "10.8.0.155"
    @

    I install a new iredmail plus iredadmin without a problem before, but now Starting from late October i could not make it.
    i have seen a forum

    https://forum.iredmail.org/search1472957384.html

    it look like i have the same issues post on 2018-09-15 03:38:31

    Dear Zhang,
      could you have a try and look?

    Thanks
    Napoleon


    0 0
  • 11/12/18--19:21: 4.2.1 Timeout errors
  • ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.8
    - Linux/BSD distribution name and version: Debian 9 (Stretch)
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): PGSQL
    - Web server (Apache or Nginx):Nginx
    - Manage mail accounts with iRedAdmin-Pro? No
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    Recently my Logwatch reports are getting stuck in smtpd with timeout errors. I turned up the logging level and this is what I see:

    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: > 127.0.0.1[127.0.0.1]:10024: XFORWARD SOURCE=LOCAL
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: > 127.0.0.1[127.0.0.1]:10024: MAIL FROM:<root@myhost.com> SIZE=16356
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: > 127.0.0.1[127.0.0.1]:10024: RCPT TO:<me.comcast.net> ORCPT=rfc822;me@comcast.net
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: > 127.0.0.1[127.0.0.1]:10024: DATA
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: smtp_stream_setup: maxtime=300 enable_deadline=0
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: < 127.0.0.1[127.0.0.1]:10024: 250 2.5.0 Ok XFORWARD
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: smtp_stream_setup: maxtime=300 enable_deadline=0
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: < 127.0.0.1[127.0.0.1]:10024: 250 2.1.0 Sender <root@myhost.com> OK
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: smtp_stream_setup: maxtime=300 enable_deadline=0
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: < 127.0.0.1[127.0.0.1]:10024: 250 2.1.5 Recipient <me@comcast.net> OK
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: smtp_stream_setup: maxtime=120 enable_deadline=0
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: < 127.0.0.1[127.0.0.1]:10024: 354 End data with <CR><LF>.<CR><LF>
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: smtp_stream_setup: maxtime=180 enable_deadline=0
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: > 127.0.0.1[127.0.0.1]:10024: .
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: > 127.0.0.1[127.0.0.1]:10024: QUIT
    Nov 12 19:38:46 web postfix/amavis/smtp[4985]: smtp_stream_setup: maxtime=1200 enable_deadline=0
    Nov 12 19:46:46 web amavis[31222]: (31222-15) (!)ESMTP ABORTING: timed out during waiting for input from client
    Nov 12 19:46:46 web amavis[31222]: (31222-15) (!)ESMTP: NOTICE: ABORTING the session: timed out during waiting for input from client
    Nov 12 19:46:46 web postfix/amavis/smtp[4985]: < 127.0.0.1[127.0.0.1]:10024: 421 4.3.2 Service shutting down, timed out during waiting for input from client

    Any other mail gets through just fine (e.g. sendmail me@comcast.net). I have to wonder about the construct of the message generated by Logwatch. Any troubleshooting suggestions would be appreciated!

    (Interestingly, rebooting the server usually makes the first message from logwatch go through without a problem, but subsequent days get "stuck")

    Thank you!


    0 0

    Dear Zhang,
      i found a bug on this release, on user interface, you can assign mail list group, but when i uncheck to remove from the mail list group, and press save change, the user is still on the group. please follow up.

    Thanks
    Napoleon


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    iRedMail     0.9.8
    iRedAdmin-Pro     2.9.0 (MySQL)
    CentOS
    ====

    Hi after spammassisan update , emails started to be denied with message (i replaced emails with  LOCAL_EMAIL (managed by iredmail) or GMAIL_EMAIL(external) not to show them here):

    554 5.7.1 <EMAIL_HERE>: Recipient address rejected: Blacklisted

    I found out in /var/log/iredapd/iredapd.log                                                                                                                                                                                   
    2018-11-13 11:18:20 INFO [209.85.208.174] RCPT, GMAIL_EMAIL -> LOCAL_EMAIL, REJECT Blacklisted [sasl_username=, sender=GMAIL_EMAIL , client_name=mail-lj1-f174.google.com, reverse_client_name=mail-lj1-f174.goog
    le.com, helo=mail-lj1-f174.google.com, encryption_protocol=TLSv1.2, process_time=0.0053s]
    2018-11-13 11:18:27 INFO Blacklisted: wblist=(1, 9, 'B')

    if i remove "check_policy_service inet:127.0.0.1:7777," from postfix config  some mail would start coming, but gmail is not coming without any bounce.

    If i check database wblist table has these :
    1    1    B
    1    3    B
    1    4    W
    1    6    W
    1    8    B
    1    9    B
    1    10    B
    1    11    B
    1    12    B
    1    14    B
    1    15    B
    1    16    B
    1    20    B
    1    21    W
    1    22    W
    1    23    B
    1    24    B
    1    25    B
    1    26    B
    1    27    B
    1    28    B
    1    29    B
    2    10    W
    3    10    W
    5    11    W


    i have remove thosw with "B" and seems things are better, but im stillnot 100% sure, why this happened and how this blacklist started blocking LOCAL mails ?

    Can anywone explain how things are working  here and how this could have happened ?


    0 0
  • 11/13/18--04:46: Re: Huge CPU usage
  • Checking the maillog log i found that :

    cat /var/log/maillog | grep 'amavisd'

    Nov 13 04:18:30 srv-main amavis[4787]: (04787-17) (!)SA TIMED OUT, backtrace: at (eval 136) line 791.\n\teval {...} called at (eval 136) line 791\n\teval {...} called at (eval 136) line 838\n\tAmavis::SpamControl::SpamAssassin::call_spamassassin('Amavis::SpamControl::SpamAssassin=HASH(0x4abff40)', 'Amavis::In::Message=HASH(0x6749618)', 'ARRAY(0x4b0d950)', undef) called at (eval 136) line 942\n\teval {...} called at (eval 136) line 951\n\tAmavis::SpamControl::SpamAssassin::check('Amavis::SpamControl::SpamAssassin=HASH(0x4abff40)', 'Amavis::In::Message=HASH(0x6749618)') called at (eval 135) line 150\n\teval {...} called at (eval 135) line 151\n\tAmavis::SpamControl::spam_scan('Amavis::SpamControl=HASH(0x4d109a0)', 'Amavis::In::Message=HASH(0x6749618)') called at /usr/sbin/amavis  line 14878\n\teval {...} called at /usr/sbin/amavisd line 16005\n\tAmavis::check_mail('Amavis::In::Message=HASH(0x6749618)', 0) called at (eval 128) line 1258\n\tAmavis::In::SMTP::p[...]
    Nov 13 04:18:42 srv-main amavis[4787]: (04787-17) (!)PRESERVING EVIDENCE in /var/spool/amavisd/tmp/amavis-20181113T041020-04787-klSmZdr9
    ...
    ...
    Nov 13 05:17:58 srv-main amavis[8339]: (08339-02) (!)connect to /var/run/clamd.amavisd/clamd.socket failed, attempt #1: Can't connect to a UNIX socket /var/run/clamd.amavisd/clamd.socket: No such file or directory
    Nov 13 05:17:59 srv-main amavis[8339]: (08339-02) (!)connect to /var/run/clamd.amavisd/clamd.socket failed, attempt #1: Can't connect to a UNIX socket /var/run/clamd.amavisd/clamd.socket: No such file or directory
    Nov 13 05:18:00 srv-main amavis[8339]: (08339-02) (!)clamav-socket: All attempts (1) failed connecting to /var/run/clamd.amavisd/clamd.socket, retrying (2)
    Nov 13 05:18:06 srv-main amavis[8339]: (08339-02) (!)connect to /var/run/clamd.amavisd/clamd.socket failed, attempt #1: Can't connect to a UNIX socket /var/run/clamd.amavisd/clamd.socket: No such file or directory
    Nov 13 05:18:06 srv-main amavis[8339]: (08339-02) (!)clamav-socket av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamd.amavisd/clamd.socket (All attempts (1) failed connecting to /var/run/clamd.amavisd/clamd.socket) at (eval 134) line 659.\n
    Nov 13 05:22:45 srv-main amavis[8339]: (08339-02) (!)run_av (clamav-clamscan): collect_results - reading aborted: timed out at /usr/sbin/amavisd line 5115.

    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release): 0.9.8
    - Linux/BSD distribution name and version: Ubuntu 18.04 lts
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL): mysql
    - Web server (Apache or Nginx): nginx
    - Manage mail accounts with iRedAdmin-Pro? No
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====


    When using the command line tool to create a new mlmmj list, does the list address have to already exist as created in iredadmin or is the address created “virtually” by mlmmj at that time? Thanks.


    0 0

    nvm, i figured it out. thanks. you don't create it in iredadmin but only with mlmmj's admin tool.


    0 0

    ==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
    - iRedMail version (check /etc/iredmail-release):  Latest
    - Linux/BSD distribution name and version: Centos 7 or ubuntu 18
    - Store mail accounts in which backend (LDAP/MySQL/PGSQL):
    - Web server (Apache or Nginx): Nginx
    - Manage mail accounts with iRedAdmin-Pro?
    - [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
    ====

    1. I have installed discourse on www.example.com and it was working fine with Nginx proxy. Then i installed iRedmail latest version and then i am able to login successfully to www.IP-address.com/iredadmin and www.IP-address.com/mail. But now i cant access to discourse. The domain www.example.com is not working. its showing "ssl redirect error". I am using Cloudflare flexible ssl and DNS.

    2. Please guide me what to do? what am i doing wrong? Is there any other nginx block configuration or do i need to change any port?

    3. I am using these 2 tutorials.
    https://www.linuxbabe.com/mail-server/u … stallation
    https://www.tecmint.com/install-discour … os-ubuntu/

    Pls help


older | 1 | .... | 1345 | 1346 | (Page 1347) | 1348 | 1349 | .... | 1394 | newer